From 800fd226608588e7f0a9f1091dc393c6e103e0c9 Mon Sep 17 00:00:00 2001
From: Holger Paradies <retabell@gmx.de>
Date: Thu, 11 Feb 2021 09:21:51 +0100
Subject: kanotix-irc-1.0.7 add yad as dialog

---
 kanotix-irc/debian/changelog | 6 ++++++
 kanotix-irc/debian/control   | 2 +-
 kanotix-irc/kanotix-irc      | 7 +++++--
 3 files changed, 12 insertions(+), 3 deletions(-)

diff --git a/kanotix-irc/debian/changelog b/kanotix-irc/debian/changelog
index 74fc261..382a2bb 100644
--- a/kanotix-irc/debian/changelog
+++ b/kanotix-irc/debian/changelog
@@ -1,3 +1,9 @@
+kanotix-irc (1.0.7) unstable; urgency=medium
+
+  * add yad as dialog
+
+ -- Holger Paradies <retabell@gmx.de>  Thu, 11 Feb 2021 09:18:07 +0100
+
 kanotix-irc (1.0.6) unstable; urgency=low
 
   * support hexchat
diff --git a/kanotix-irc/debian/control b/kanotix-irc/debian/control
index 4733c0c..04dc81e 100644
--- a/kanotix-irc/debian/control
+++ b/kanotix-irc/debian/control
@@ -8,7 +8,7 @@ Standards-Version: 3.7.2
 Package: kanotix-irc
 Architecture: all
 Depends: dialog, irssi | irssi-text | bitchx | weechat-curses
-Suggests: konversation (>> 0.18) | ksirc | xchat, kdialog | xdialog | zenity, python, distro-defaults, xterm | x-terminal-emulator, infobash
+Suggests: konversation (>> 0.18) | ksirc | xchat, kdialog | xdialog | zenity | yad, python, distro-defaults, xterm | x-terminal-emulator, infobash
 Description: Start a suitable IRC client to enter #kanotix
  kanotix-irc provides an easy way to choose a nickname and to enter the
  #kanotix irc channel.
diff --git a/kanotix-irc/kanotix-irc b/kanotix-irc/kanotix-irc
index ab0bde7..9ffa467 100755
--- a/kanotix-irc/kanotix-irc
+++ b/kanotix-irc/kanotix-irc
@@ -31,6 +31,7 @@ DIALOG="$(which dialog)"			|| DIALOG="/usr/bin/dialog"
 KDIALOG="$(which kdialog)"			|| KDIALOG="/usr/bin/kdialog"
 XDIALOG="$(which Xdialog)"			|| XDIALOG="/usr/bin/Xdialog"
 ZENITY="$(which zenity)"			|| ZENITY="/usr/bin/zenity"
+YAD="$(which yad)"				|| YAD="/usr/bin/yad"
 MKTEMP="$(which mktemp)"			|| XTERMINAL="/bin/mktemp"
 SU="$(which su)"				|| SU="/bin/su"
 XTERMINAL="$(which x-terminal-emulator)"	|| XTERMINAL="/usr/bin/x-terminal-emulator"
@@ -60,6 +61,8 @@ inputbox()
 			"$XDIALOG" --title "$TITLE" --inputbox "$TEXT" $HEIGHT $WIDTH "$INIT"
 		elif [ -x "$ZENITY" ]; then
 			"$ZENITY" --title="$TITLE" --entry --text="$TEXT" --entry-text="$INIT"
+		elif [ -x "$YAD" ]; then
+			"$YAD" --title="$TITLE" --entry --text="$TEXT" --entry-text="$INIT"
 		fi		
 	else
 		"$DIALOG" --stdout --title "$TITLE" --inputbox "$TEXT" $HEIGHT $WIDTH "$INIT"
@@ -463,8 +466,8 @@ else
 			exit 998
 		fi
 	done
-	if ! [ -x "$XDIALOG" -o -x "$KDIALOG" -o -x "$ZENITY" ]; then
-		echo "$XDIALOG, $KDIALOG and $ZENITY are missing, terminate abnormally"
+	if ! [ -x "$XDIALOG" -o -x "$KDIALOG" -o -x "$ZENITY" -o -x "$YAD" ]; then
+		echo "$XDIALOG, $KDIALOG, $ZENITY and $YAD are missing, terminate abnormally"
 		exit 998
 	fi
 fi
-- 
cgit v1.0