From d48660411e26c18fb76fa0c83a89f8e2710fe926 Mon Sep 17 00:00:00 2001
From: Holger Paradies <retabell@gmx.de>
Date: Tue, 24 Dec 2013 10:19:14 +0100
Subject: kanotix-irc-1.0.1

---
 kanotix-irc/debian/changelog           |  6 ++++++
 kanotix-irc/kanotix-irc                | 31 ++++++++++++++++++++++---------
 kanotix-irc/skel/.xchat2/commands.conf |  2 ++
 kanotix-irc/skel/.xchat2/xchat.conf    |  8 ++++++++
 4 files changed, 38 insertions(+), 9 deletions(-)
 create mode 100644 kanotix-irc/skel/.xchat2/commands.conf
 create mode 100644 kanotix-irc/skel/.xchat2/xchat.conf

diff --git a/kanotix-irc/debian/changelog b/kanotix-irc/debian/changelog
index 77f3886..c4b0cd0 100644
--- a/kanotix-irc/debian/changelog
+++ b/kanotix-irc/debian/changelog
@@ -1,3 +1,9 @@
+kanotix-irc (1.0.1) unstable; urgency=low
+
+  * add small xchat2 preconfig and combine with tmp config 
+
+ -- Holger Paradies <retabell@gmx.de>  Tue, 26 Feb 2013 13:32:44 +0100
+
 kanotix-irc (1.0.0) unstable; urgency=low
 
   * Zenity support added by Jörg Schirottke <master@kanotix.com>
diff --git a/kanotix-irc/kanotix-irc b/kanotix-irc/kanotix-irc
index a3afd32..cd23d0c 100755
--- a/kanotix-irc/kanotix-irc
+++ b/kanotix-irc/kanotix-irc
@@ -329,6 +329,28 @@ kanotix_xchat()
 {
 	XCHATCFG="$($MKTEMP -dp /tmp/ .xchat2-XXXXXXXXXX)"
 
+        if [ -e ~/.xchat2/ ]; then
+		cp -r ~/.xchat2/* "$XCHATCFG/"
+		# delete improper lines
+	sed -i '/gui_join_dialog/d;
+		/gui_slist_skip/d;
+		/gui_slist_select/d;
+		/irc_nick1/d;
+		/irc_nick2/d;
+		/irc_nick3/d;
+		/irc_user_name/d;
+		/irc_real_name/d' "$XCHATCFG/xchat.conf"
+	fi
+	cat <<_EOF_ >>"$XCHATCFG/xchat.conf"
+gui_join_dialog = 0
+gui_slist_select = 0
+gui_slist_skip = 1
+irc_nick1 = $NICK
+irc_nick2 = ${NICK}_
+irc_nick3 = ${NICK}__
+_EOF_
+
+
 	cat <<_EOF_ >"$XCHATCFG/servlist_.conf"
 N=FreeNode
 J=#kanotix
@@ -350,15 +372,6 @@ S=irc.freenode.net/$FLL_IRC_PORT
 S=irc.freenode.net/+7000
 _EOF_
 
-	cat <<_EOF_ >"$XCHATCFG/xchat.conf"
-gui_join_dialog = 0
-gui_slist_select = 0
-gui_slist_skip = 1
-irc_nick1 = $NICK
-irc_nick2 = ${NICK}_
-irc_nick3 = ${NICK}__
-_EOF_
-
 	cat <<_EOF_ >"$XCHATCFG/commands.conf"
 NAME cmd
 CMD exec -o &2
diff --git a/kanotix-irc/skel/.xchat2/commands.conf b/kanotix-irc/skel/.xchat2/commands.conf
new file mode 100644
index 0000000..dbdd1f1
--- /dev/null
+++ b/kanotix-irc/skel/.xchat2/commands.conf
@@ -0,0 +1,2 @@
+NAME cmd
+CMD exec -o &2
diff --git a/kanotix-irc/skel/.xchat2/xchat.conf b/kanotix-irc/skel/.xchat2/xchat.conf
new file mode 100644
index 0000000..ef423bc
--- /dev/null
+++ b/kanotix-irc/skel/.xchat2/xchat.conf
@@ -0,0 +1,8 @@
+version = 2.8.8
+completion_sort = 1
+gui_input_spell = 0
+stamp_text = 1
+tab_layout = 0
+tab_pos = 6
+text_font = Monospace 12
+text_show_marker = 0
-- 
cgit v1.0