summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control6
-rw-r--r--debian/postinst28
-rw-r--r--debian/prerm23
-rwxr-xr-xdebian/rules4
5 files changed, 62 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index e67f5b0..7cff069 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+live-helper (1.0~a20-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 23 Jul 2007 00:00:00 +0200
+
live-helper (1.0~a19-1) unstable; urgency=medium
* New upstream release:
diff --git a/debian/control b/debian/control
index 04fa651..47c3255 100644
--- a/debian/control
+++ b/debian/control
@@ -12,9 +12,6 @@ Package: live-helper
Architecture: all
Depends: cdebootstrap (>= 0.3.15) | debootstrap (>= 0.3.3.2)
Suggests: genisoimage | mkisofs, memtest86+ | memtest86, mtools, squashfs-tools | genext2fs, syslinux | grub
-Conflicts: live-package
-Replaces: live-package
-Provides: make-live
Description: Debian Live helper programs
Live-helper is a collection of programs that can be used to build Debian Live
system images. The philosophy behind live-helper is to provide a collection of
@@ -22,7 +19,6 @@ Description: Debian Live helper programs
to automate building of a Live system.
.
A typical program that uses live-helper will call several live-helper commands
- in sequence. Live-helper commands are all named with a "lh_" prefix. Examples
- of such a program that uses live-helper is make-live (included here).
+ in sequence. Live-helper commands are all named with a "lh_" prefix.
.
Homepage: <http://debian-live.alioth.debian.org/>
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..9137a2c
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ configure)
+ update-alternatives --install /usr/share/live-helper/templates \
+ live-helper_templates \
+ /usr/share/live-helper/templates.debian 100
+
+ update-alternatives --install /usr/share/live-helper/includes \
+ live-helper_includes \
+ /usr/share/live-helper/includes.debian 100
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 0000000..e30345b
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ remove|upgrade|deconfigure)
+ update-alternatives --remove live-helper_includes /usr/share/live-helper/includes.debian
+ update-alternatives --remove live-helper_templates /usr/share/live-helper/templates.debian
+ ;;
+
+ failed-upgrade)
+
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
index 83011f5..92b7fff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,6 +29,10 @@ install: build
install -D -m 0644 debian/default debian/live-helper/etc/default/live-helper
+ # Preparing alternatives
+ mv debian/live-helper/usr/share/live-helper/includes debian/live-helper/usr/share/live-helper/includes.debian
+ mv debian/live-helper/usr/share/live-helper/templates debian/live-helper/usr/share/live-helper/templates.debian
+
# Removing double files
rm -f debian/live-helper/usr/share/doc/live-helper/COPYING
rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog