From 9eac19deb8a47f75285d223c2f93c310815401a3 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel@debian.org>
Date: Sun, 23 Sep 2007 10:05:18 +0200
Subject: Adding live-helper 1.0~a24-1.

---
 Makefile                                |   6 +-
 debian/changelog                        |   8 ++
 docs/ChangeLog                          |   5 +
 functions/common.sh                     |   2 +-
 helpers/lh_clean                        | 159 ++++++++++++++++----------------
 manpages/lh_binary.de.1                 |   2 +-
 manpages/lh_binary.en.1                 |   2 +-
 manpages/lh_bootstrap.de.1              |   2 +-
 manpages/lh_bootstrap.en.1              |   2 +-
 manpages/lh_bootstrap_cdebootstrap.de.1 |   2 +-
 manpages/lh_bootstrap_cdebootstrap.en.1 |   2 +-
 manpages/lh_bootstrap_debootstrap.de.1  |   2 +-
 manpages/lh_bootstrap_debootstrap.en.1  |   2 +-
 manpages/lh_build.de.1                  |   2 +-
 manpages/lh_build.en.1                  |   2 +-
 manpages/lh_chroot.de.1                 |   2 +-
 manpages/lh_chroot.en.1                 |   2 +-
 manpages/lh_clean.de.1                  |   2 +-
 manpages/lh_clean.en.1                  |   2 +-
 manpages/lh_config.de.1                 |   2 +-
 manpages/lh_config.en.1                 |   2 +-
 manpages/lh_source.de.1                 |   2 +-
 manpages/lh_source.en.1                 |   2 +-
 manpages/lh_testroot.de.1               |   2 +-
 manpages/lh_testroot.en.1               |   2 +-
 manpages/live-helper.de.7               |   2 +-
 manpages/live-helper.en.7               |   2 +-
 27 files changed, 120 insertions(+), 104 deletions(-)

diff --git a/Makefile b/Makefile
index 7fbda83..5aeb27b 100644
--- a/Makefile
+++ b/Makefile
@@ -91,9 +91,9 @@ uninstall:
 update:
 	set -e; for FILE in functions/*.sh examples/cron/*.sh manpages/*.de.* manpages/*.en.*; \
 	do \
-		sed -i	-e 's/2007\\-08\\-13/2007\\-08\\-20/' \
-			-e 's/13.08.2007/20.08.2007/' \
-			-e 's/1.0~a23/1.0~a24/' \
+		sed -i	-e 's/2007\\-08\\-20/2007\\-08\\-27/' \
+			-e 's/20.08.2007/27.08.2007/' \
+			-e 's/1.0~a24/1.0~a25/' \
 		$$FILE; \
 	done
 
diff --git a/debian/changelog b/debian/changelog
index 41552df..360beec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+live-helper (1.0~a24-1) unstable; urgency=medium
+
+  * New upstream release:
+    - lh_clean accepts more than one argument at the same time
+      (Closes: #439947).
+
+ -- Daniel Baumann <daniel@debian.org>  Mon, 20 Aug 2007 00:00:00 +0200
+
 live-helper (1.0~a23-1) unstable; urgency=medium
 
   * New upstream release.
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 4f8a769..fcc9335 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,8 @@
+2007-08-28  Daniel Baumann  <daniel@debian.org>
+
+	* helpers/lh_clean:
+	  - Accepting more than one parameter at the same time.
+
 2007-08-14  Daniel Baumann  <daniel@debian.org>
 
 	* helpers/*:
diff --git a/functions/common.sh b/functions/common.sh
index c7f8269..e56b80f 100755
--- a/functions/common.sh
+++ b/functions/common.sh
@@ -10,4 +10,4 @@
 set -e
 
 PROGRAM="`basename ${0}`"
-VERSION="1.0~a23"
+VERSION="1.0~a24"
diff --git a/helpers/lh_clean b/helpers/lh_clean
index 4c52ed2..021100f 100755
--- a/helpers/lh_clean
+++ b/helpers/lh_clean
@@ -35,81 +35,84 @@ Set_defaults
 
 rm -f .lock
 
-case "${1}" in
-	all)
-		"${0}" chroot
-		"${0}" binary
-		"${0}" stage
-		"${0}" source
-
-		if [ -d chroot ]
-		then
-			mkdir -p .stage
-			touch .stage/bootstrap
-		fi
-		;;
-
-	cache)
-		${LH_ROOT_COMMAND} rm -rf cache
-		;;
-
-	chroot)
-		Echo_message "Cleaning chroot"
-		${LH_ROOT_COMMAND} umount -f chroot/sys > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/proc/sys/fs/binfmt_misc > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/proc > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/lib/init/rw > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/dev/shm > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/dev/pts > /dev/null 2>&1 || true
-		${LH_ROOT_COMMAND} umount -f chroot/dev > /dev/null 2>&1 || true
-
-		${LH_ROOT_COMMAND} rm -rf chroot chroot.tmp
-
-		if [ "${PURGE}" != "true" ] && [ -d cache/stages_bootstrap ]
-		then
-			${LH_ROOT_COMMAND} cp -a cache/stages_bootstrap chroot
-			mkdir -p .stage
-			touch .stage/bootstrap
-		fi
-
-		rm -f .stage/chroot*
-		;;
-
-	binary)
-                ${LH_ROOT_COMMAND} umount -f binary.tmp > /dev/null 2>&1 || true
-		rm -rf binary.tmp binary.deb binary.udeb
-		rm -f binary.iso
-		rm -f binary.img
-		rm -f binary*.tar.gz
-		rm -f binary.sh
-
-		rm -rf binary
-		rm -rf tftpboot
-
-		rm -f .stage/binary*
-		;;
-
-	purge)
-		PURGE="true" "${0}" all
-		"${0}" cache
-		;;
-
-	stage)
-		rm -rf .stage
-		;;
-
-	source)
-		rm -f source.iso
-		rm -f source.img
-		rm -f source*.tar
-		rm -f source*.tar.gz
-
-		rm -rf source
-
-		rm -f .stage/source*
-		;;
-
-	*)
-		"${0}" all
-		;;
-esac
+for ARGUMENT in ${@}
+do
+	case "${ARGUMENT}" in
+		all)
+			"${0}" chroot
+			"${0}" binary
+			"${0}" stage
+			"${0}" source
+
+			if [ -d chroot ]
+			then
+				mkdir -p .stage
+				touch .stage/bootstrap
+			fi
+			;;
+
+		cache)
+			${LH_ROOT_COMMAND} rm -rf cache
+			;;
+
+		chroot)
+			Echo_message "Cleaning chroot"
+			${LH_ROOT_COMMAND} umount -f chroot/sys > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/proc/sys/fs/binfmt_misc > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/proc > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/lib/init/rw > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/dev/shm > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/dev/pts > /dev/null 2>&1 || true
+			${LH_ROOT_COMMAND} umount -f chroot/dev > /dev/null 2>&1 || true
+
+			${LH_ROOT_COMMAND} rm -rf chroot chroot.tmp
+
+			if [ "${PURGE}" != "true" ] && [ -d cache/stages_bootstrap ]
+			then
+				${LH_ROOT_COMMAND} cp -a cache/stages_bootstrap chroot
+				mkdir -p .stage
+				touch .stage/bootstrap
+			fi
+
+			rm -f .stage/chroot*
+			;;
+
+		binary)
+	                ${LH_ROOT_COMMAND} umount -f binary.tmp > /dev/null 2>&1 || true
+			rm -rf binary.tmp binary.deb binary.udeb
+			rm -f binary.iso
+			rm -f binary.img
+			rm -f binary*.tar.gz
+			rm -f binary.sh
+
+			rm -rf binary
+			rm -rf tftpboot
+
+			rm -f .stage/binary*
+			;;
+
+		purge)
+			PURGE="true" "${0}" all
+			"${0}" cache
+			;;
+
+		stage)
+			rm -rf .stage
+			;;
+
+		source)
+			rm -f source.iso
+			rm -f source.img
+			rm -f source*.tar
+			rm -f source*.tar.gz
+
+			rm -rf source
+
+			rm -f .stage/source*
+			;;
+
+		*)
+			"${0}" all
+			;;
+	esac
+done
diff --git a/manpages/lh_binary.de.1 b/manpages/lh_binary.de.1
index 3100a88..61013a6 100644
--- a/manpages/lh_binary.de.1
+++ b/manpages/lh_binary.de.1
@@ -1,4 +1,4 @@
-.TH LH_BINARY 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BINARY 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_binary \- Meta\-Helper f\[:u]r lh_binary_*
diff --git a/manpages/lh_binary.en.1 b/manpages/lh_binary.en.1
index 97fc3bd..b4f9b25 100644
--- a/manpages/lh_binary.en.1
+++ b/manpages/lh_binary.en.1
@@ -1,4 +1,4 @@
-.TH LH_BINARY 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BINARY 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_binary \- meta\-helper for lh_binary_*
diff --git a/manpages/lh_bootstrap.de.1 b/manpages/lh_bootstrap.de.1
index db538f5..abbbfb4 100644
--- a/manpages/lh_bootstrap.de.1
+++ b/manpages/lh_bootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap \- Meta\-Helper f\[:u]r lh_bootstrap_*
diff --git a/manpages/lh_bootstrap.en.1 b/manpages/lh_bootstrap.en.1
index afaec2c..ec6066f 100644
--- a/manpages/lh_bootstrap.en.1
+++ b/manpages/lh_bootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap \- meta\-helper for lh_bootstrap_*
diff --git a/manpages/lh_bootstrap_cdebootstrap.de.1 b/manpages/lh_bootstrap_cdebootstrap.de.1
index e1c5805..f31fc3a 100644
--- a/manpages/lh_bootstrap_cdebootstrap.de.1
+++ b/manpages/lh_bootstrap_cdebootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap_cdebootstrap \- erstellt ein Debian-System mit \fIcdebootstrap\fR(1)
diff --git a/manpages/lh_bootstrap_cdebootstrap.en.1 b/manpages/lh_bootstrap_cdebootstrap.en.1
index 23f48b4..7132855 100644
--- a/manpages/lh_bootstrap_cdebootstrap.en.1
+++ b/manpages/lh_bootstrap_cdebootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_CDEBOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap_cdebootstrap \- bootstrap a Debian system with \fIcdebootstrap\fR(1)
diff --git a/manpages/lh_bootstrap_debootstrap.de.1 b/manpages/lh_bootstrap_debootstrap.de.1
index 7a453cb..f37a73e 100644
--- a/manpages/lh_bootstrap_debootstrap.de.1
+++ b/manpages/lh_bootstrap_debootstrap.de.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap_debootstrap \- erstellt ein Debian-System mit \fIdebootstrap\fR(8)
diff --git a/manpages/lh_bootstrap_debootstrap.en.1 b/manpages/lh_bootstrap_debootstrap.en.1
index e5b0e29..5443503 100644
--- a/manpages/lh_bootstrap_debootstrap.en.1
+++ b/manpages/lh_bootstrap_debootstrap.en.1
@@ -1,4 +1,4 @@
-.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BOOTSTRAP_DEBOOTSTRAP 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_bootstrap_debootstrap \- bootstrap a Debian system with \fIdebootstrap\fR(8)
diff --git a/manpages/lh_build.de.1 b/manpages/lh_build.de.1
index 4895e1a..73213c5 100644
--- a/manpages/lh_build.de.1
+++ b/manpages/lh_build.de.1
@@ -1,4 +1,4 @@
-.TH LH_BUILD 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_BUILD 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_build \- erstellen eines Live-Systemes
diff --git a/manpages/lh_build.en.1 b/manpages/lh_build.en.1
index 09fd642..5b9e6f1 100644
--- a/manpages/lh_build.en.1
+++ b/manpages/lh_build.en.1
@@ -1,4 +1,4 @@
-.TH LH_BUILD 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_BUILD 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_build \- building a live system
diff --git a/manpages/lh_chroot.de.1 b/manpages/lh_chroot.de.1
index a4b3cbb..5aa8aaa 100644
--- a/manpages/lh_chroot.de.1
+++ b/manpages/lh_chroot.de.1
@@ -1,4 +1,4 @@
-.TH LH_CHROOT 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CHROOT 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_chroot \- Meta\-Helper f\[:u]r lh_chroot_*
diff --git a/manpages/lh_chroot.en.1 b/manpages/lh_chroot.en.1
index 7139ac0..f587ca0 100644
--- a/manpages/lh_chroot.en.1
+++ b/manpages/lh_chroot.en.1
@@ -1,4 +1,4 @@
-.TH LH_CHROOT 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CHROOT 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_chroot \- meta\-helper for lh_chroot_*
diff --git a/manpages/lh_clean.de.1 b/manpages/lh_clean.de.1
index 06df505..8c39bf4 100644
--- a/manpages/lh_clean.de.1
+++ b/manpages/lh_clean.de.1
@@ -1,4 +1,4 @@
-.TH LH_CLEAN 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CLEAN 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_clean \- r\[:a]umt das Build-Verzeichnis auf
diff --git a/manpages/lh_clean.en.1 b/manpages/lh_clean.en.1
index 2684ef7..64bd8bb 100644
--- a/manpages/lh_clean.en.1
+++ b/manpages/lh_clean.en.1
@@ -1,4 +1,4 @@
-.TH LH_CLEAN 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CLEAN 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_clean \- clean up system build directories
diff --git a/manpages/lh_config.de.1 b/manpages/lh_config.de.1
index 126f48b..0c3e1bc 100644
--- a/manpages/lh_config.de.1
+++ b/manpages/lh_config.de.1
@@ -1,4 +1,4 @@
-.TH LH_CONFIG 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_CONFIG 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_config \- erstellt live-helper(7) Konfiguration
diff --git a/manpages/lh_config.en.1 b/manpages/lh_config.en.1
index 1825ff1..c5129f0 100644
--- a/manpages/lh_config.en.1
+++ b/manpages/lh_config.en.1
@@ -1,4 +1,4 @@
-.TH LH_CONFIG 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_CONFIG 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_config \- create configuration for live-helper(7)
diff --git a/manpages/lh_source.de.1 b/manpages/lh_source.de.1
index c819d3f..18aabbc 100644
--- a/manpages/lh_source.de.1
+++ b/manpages/lh_source.de.1
@@ -1,4 +1,4 @@
-.TH LH_SOURCE 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_SOURCE 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_source \- Meta\-Helper f\[:u]r lh_source_*
diff --git a/manpages/lh_source.en.1 b/manpages/lh_source.en.1
index e39090d..e5693a6 100644
--- a/manpages/lh_source.en.1
+++ b/manpages/lh_source.en.1
@@ -1,4 +1,4 @@
-.TH LH_SOURCE 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_SOURCE 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_source \- meta\-helper for lh_source_*
diff --git a/manpages/lh_testroot.de.1 b/manpages/lh_testroot.de.1
index 5701951..0f35ac1 100644
--- a/manpages/lh_testroot.de.1
+++ b/manpages/lh_testroot.de.1
@@ -1,4 +1,4 @@
-.TH LH_TESTROOT 1 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LH_TESTROOT 1 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_testroot \- stellt sicher dass das System als root gebaut wird
diff --git a/manpages/lh_testroot.en.1 b/manpages/lh_testroot.en.1
index 8ce9ec6..6f415da 100644
--- a/manpages/lh_testroot.en.1
+++ b/manpages/lh_testroot.en.1
@@ -1,4 +1,4 @@
-.TH LH_TESTROOT 1 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LH_TESTROOT 1 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 lh_testroot \- ensure that a system is built as root
diff --git a/manpages/live-helper.de.7 b/manpages/live-helper.de.7
index 08f17a6..afadf2a 100644
--- a/manpages/live-helper.de.7
+++ b/manpages/live-helper.de.7
@@ -1,4 +1,4 @@
-.TH LIVE\-HELPER 7 "13.08.2007" "1.0~a23" "live\-helper"
+.TH LIVE\-HELPER 7 "20.08.2007" "1.0~a24" "live\-helper"
 
 .SH NAME
 live\-helper \- Debian Live Helper-Programme
diff --git a/manpages/live-helper.en.7 b/manpages/live-helper.en.7
index bdb22bf..097c296 100644
--- a/manpages/live-helper.en.7
+++ b/manpages/live-helper.en.7
@@ -1,4 +1,4 @@
-.TH LIVE\-HELPER 7 "2007\-08\-13" "1.0~a23" "live\-helper"
+.TH LIVE\-HELPER 7 "2007\-08\-20" "1.0~a24" "live\-helper"
 
 .SH NAME
 live\-helper \- Debian Live helper programs
-- 
cgit v1.0