From d2b526b342cf6ababb1494dce5d4f6b30f3fb718 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel@debian.org>
Date: Sun, 23 Sep 2007 10:04:34 +0200
Subject: Adding live-package 0.99.10-1.

---
 debian/changelog          |  6 ++++++
 src/config                | 10 ++++++++--
 src/main.sh               |  2 +-
 src/scripts/02defaults.sh |  2 +-
 src/scripts/14chroot.sh   |  6 ++++++
 src/scripts/23net.sh      |  6 ++++++
 templates/syslinux/f4.txt | 10 +++++-----
 7 files changed, 33 insertions(+), 9 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 831c7ce..18e0c40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+live-package (0.99.10-1) unstable; urgency=medium
+
+  * New upstream release.
+
+ -- Daniel Baumann <daniel@debian.org>  Mon,  9 Oct 2006 00:00:00 +0200
+
 live-package (0.99.9-1) unstable; urgency=medium
 
   * New upstream release:
diff --git a/src/config b/src/config
index a319ada..3cabd6f 100644
--- a/src/config
+++ b/src/config
@@ -70,7 +70,7 @@
 LIVE_REPOSITORY_bpo="http://www.backports.org/debian/"
 LIVE_REPOSITORY_KEY_bpo="http://backports.org/debian/archive.key"
 LIVE_REPOSITORY_KEYRING_bpo=""
-LIVE_REPOSITORY_DISTRIBUTION=""
+LIVE_REPOSITORY_DISTRIBUTION_bpo="sarge-backports"
 LIVE_REPOSITORY_SECTIONS_bpo="main contrib non-free"
 
 LIVE_REPOSITORY_edu="http://ftp.skolelinux.org/skolelinux/"
@@ -82,9 +82,15 @@ LIVE_REPOSITORY_SECTIONS_edu="local"
 LIVE_REPOSITORY_duo="http://ftp.debian-unofficial.org/debian/"
 LIVE_REPOSITORY_KEY_duo="http://ftp-master.debian-unofficial.org/key_2006.asc"
 LIVE_REPOSITORY_KEYRING_duo=""
-LIVE_REPOSITORY_DISTRIBUTION=""
+LIVE_REPOSITORY_DISTRIBUTION_duo=""
 LIVE_REPOSITORY_SECTIONS_duo="main contrib non-free restricted"
 
+LIVE_REPOSITORY_fai="http://www.informatik.uni-koeln.de/fai/download/"
+LIVE_REPOSITORY_KEY_fai=""
+LIVE_REPOSITORY_KEYRING_fai=""
+LIVE_REPOSITORY_DISTRIBUTION_fai="etch"
+LIVE_REPOSITORY_SECTIONS_fai="koeln"
+
 # Debian section		(Default: main)
 #LIVE_SECTION="main"
 
diff --git a/src/main.sh b/src/main.sh
index aa2e246..7367e84 100755
--- a/src/main.sh
+++ b/src/main.sh
@@ -28,7 +28,7 @@ set -e
 BASE="/usr/share/make-live"
 CONFIG="/etc/make-live.conf"
 PROGRAM="`basename ${0}`"
-VERSION="0.99.9"
+VERSION="0.99.10"
 
 CODENAME_OLDSTABLE="woody"
 CODENAME_STABLE="sarge"
diff --git a/src/scripts/02defaults.sh b/src/scripts/02defaults.sh
index d23c021..dffa490 100644
--- a/src/scripts/02defaults.sh
+++ b/src/scripts/02defaults.sh
@@ -53,7 +53,7 @@ Defaults ()
 	# Set debian distribution
 	if [ -z "${LIVE_DISTRIBUTION}" ]
 	then
-		LIVE_DISTRIBUTION="unstable"
+		LIVE_DISTRIBUTION="testing"
 	else
 		case "${LIVE_DISTRIBUTION}" in
 			"${CODENAME_OLDSTABLE}")
diff --git a/src/scripts/14chroot.sh b/src/scripts/14chroot.sh
index e264128..bf38040 100644
--- a/src/scripts/14chroot.sh
+++ b/src/scripts/14chroot.sh
@@ -27,6 +27,9 @@ Chroot ()
 		# Configure network
 		Patch_network apply
 
+		# Mount proc
+		mount proc-live -t proc "${LIVE_CHROOT}"/proc
+
 		# Configure sources.list
 		Indices custom
 
@@ -129,6 +132,9 @@ Chroot ()
 		# Remove cdebootstrap packages cache
 		rm -rf "${LIVE_CHROOT}"/var/cache/bootstrap
 
+		# Unmount proc
+		umount "${LIVE_CHROOT}"/proc
+
 		# Deconfigure network
 		Patch_network deapply
 
diff --git a/src/scripts/23net.sh b/src/scripts/23net.sh
index 02869dd..78a0361 100644
--- a/src/scripts/23net.sh
+++ b/src/scripts/23net.sh
@@ -28,9 +28,15 @@ Net ()
 			mv "${MANIFEST}" "${LIVE_ROOT}"/binary/casper/
 		done
 
+		# Mount proc
+		mount proc-live -t proc "${LIVE_CHROOT}"/proc
+
 		# Installing smbfs
 		Chroot_exec "apt-get install --yes --force-yes smbfs"
 
+		# Unmount proc
+		umount "${LIVE_CHROOT}"/proc
+
 		if [ "${LIVE_ARCHITECTURE}" = "amd64" ] || [ "${LIVE_ARCHITECTURE}" = "i386" ]
 		then
 			if [ ! -d "${LIVE_CHROOT}"/etc/initramfs-tools ]
diff --git a/templates/syslinux/f4.txt b/templates/syslinux/f4.txt
index 3e6bcdc..e0c780c 100644
--- a/templates/syslinux/f4.txt
+++ b/templates/syslinux/f4.txt
@@ -5,17 +5,17 @@ in combination with the boot method (see <09F307>).
 0f
 OPTION                                 PARAMETER TO SPECIFY07
 Check media for defects                0fintegrity-check07
-Enable persistent media                0fpersistent07
+Set a static ip (no dhcp)              0fip=if,add,netm,gatew07
+Set a static ip (no dhcp)              0fip=if,add,netm,gatew07
+Set a default locale                   0flocale=<locale>07
 Suppress some debug informations       0fquiet07
-Show internal filesystem               0fshow-cow07
+Show internal filesystems              0fshowmounts07
 Copy the live media to memory          0ftoram07
 Set initial display mode               0fvga=<mode>07
 
 For example:
 
-  boot: linux quiet vga=792
-
-
+  boot: linux quiet vga=792 locale=it_IT.UTF-8
 
 
 
-- 
cgit v1.0