From 76c75b83c5ed877df9295570e0a6ff6fbd204c90 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel@debian.org>
Date: Sun, 18 Nov 2007 16:15:43 +0100
Subject: Moving sanity check in lh_clean to the earliest possibility.

---
 helpers/lh_clean | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/helpers/lh_clean b/helpers/lh_clean
index 4f0c526..4a5baa4 100755
--- a/helpers/lh_clean
+++ b/helpers/lh_clean
@@ -33,6 +33,13 @@ Read_conffile config/source
 Read_conffile "${LH_CONFIG}"
 Set_defaults
 
+# Avoid cases were users accidentally nuke their config/binary
+if [ ! -d config ] || [ "$(basename ${PWD})" = "config" ]
+then
+	Echo_error "${PWD} is not a good Debian Live working directory to clean."
+	exit 1
+fi
+
 rm -f .lock
 
 if [ -z "${@}" ]
@@ -42,13 +49,6 @@ else
 	ARGUMENTS="${@}"
 fi
 
-# Avoid cases were users accidentally nuke their config/binary
-if [ ! -d config ] || [ "$(basename ${PWD})" = "config" ]
-then
-	Echo_error "${PWD} is not a good Debian Live working directory to clean."
-	exit 1
-fi
-
 for ARGUMENT in ${ARGUMENTS}
 do
 	case "${ARGUMENT}" in
-- 
cgit v1.0