summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/copyright3
-rw-r--r--debian/cron.daily67
-rw-r--r--debian/default13
-rwxr-xr-xdebian/rules2
5 files changed, 91 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7827510..f09a07f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+live-package (0.99.18-1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Daniel Baumann <daniel@debian.org> Thu, 25 Jan 2007 08:29:00 +0100
+
live-package (0.99.17-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/copyright b/debian/copyright
index 407c2f9..5a6aab6 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -54,3 +54,6 @@ License (contrib/syslinux-splash/*, templates/isolinux/splash.rle):
Note: we would appreciate that you make the image a link to
http://www.debian.org/ if you use it on a web page.
+
+The Debian packaging is (C) 2006-2007, Daniel Baumann <daniel@debian.org> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/debian/cron.daily b/debian/cron.daily
new file mode 100644
index 0000000..50f34b5
--- /dev/null
+++ b/debian/cron.daily
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Check for make-live executable
+if [ ! -x /usr/sbin/make-live ]
+then
+ exit 0
+fi
+
+# Check for make-live default
+if [ -r /etc/default/make-live ]
+then
+ . /etc/default/make-live
+else
+ echo "E: /etc/default/make-live missing."
+ exit 1
+fi
+
+# Check for autobuild
+if [ "${AUTOBUILD}" = "false" ]
+then
+ exit 0
+fi
+
+# Check for build directory
+if [ ! -d "${DIRECTORY}" ]
+then
+ mkdir -p "${DIRECTORY}"
+else
+ # FIXME: maybe we should just remove the left overs.
+ echo "E: ${DIRECTORY} needs cleanup."
+ exit 1
+fi
+
+# Process image autobuilding
+cd "${DIRECTORY}"
+
+for DISTRIBUTION in ${DISTRIBUTIONS}
+do
+ for FLAVOUR in ${FLAVOURS}
+ do
+ if [ ! -f "${SERVER}"/daily-release/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${FLAVOUR}_${DATE}.txt ]
+ then
+ # Generating images
+ mkdir debian-live
+ make-live -d ${DISTRIBUTION} -p ${FLAVOUR} -m ${MIRROR} ${OPTIONS} > debian-live/log.txt 2>&1
+ fi
+
+ if [ -f debian-live/binary.iso ] && [ -f debian-live/source.iso ]
+ then
+ # Moving images
+ mkdir -p "${SERVER}"/daily-release/${DATE}/log
+ mv debian-live/log.txt "${SERVER}"/daily-release/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${FLAVOUR}_${DATE}.txt
+
+ mkdir -p "${SERVER}"/daily-release/${DATE}/${ARCHITECTURE}
+ mv debian-live/binary.iso "${SERVER}"/daily-release/${DATE}/${ARCHITECTURE}/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${FLAVOUR}.iso
+
+ mkdir -p "${SERVER}"/daily-release/${DATE}/source
+ mv debian-live/source.iso "${SERVER}"/daily-release/${DATE}/source/debian-live-${DISTRIBUTION}-source-${FLAVOUR}.iso
+ fi
+
+ rm -rf debian-live
+ done
+done
+
+# Cleanup
+umount -f "${DIRECTORY}"/debian-live/chroot/proc > /dev/null 2>&1
+rm -rf "${DIRECTORY}"
diff --git a/debian/default b/debian/default
new file mode 100644
index 0000000..bd8e7fd
--- /dev/null
+++ b/debian/default
@@ -0,0 +1,13 @@
+# Defaults for make-live cron.daily
+
+AUTOBUILD="false"
+
+DISTRIBUTIONS="etch sid"
+FLAVOURS="minimal standard kde gnome xfce"
+MIRROR="http://ftp.debian.org/debian/"
+OPTIONS="--with-source"
+
+DIRECTORY="/srv/tmp/make-live"
+SERVER="/srv/debian-live"
+ARCHITECTURE="`dpkg --print-architecture`"
+DATE="`date +%Y%m%d`"
diff --git a/debian/rules b/debian/rules
index d2e32d5..ef72dea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,7 @@ install: build
# Installing package
$(MAKE) install DESTDIR=$(CURDIR)/debian/live-package
+ install -D debian/default debian/live-package/etc/default/make-live
binary-arch: build install
@@ -32,6 +33,7 @@ binary-indep: build install
dh_installchangelogs ChangeLog
dh_installdocs
dh_install
+ dh_installcron
dh_compress
dh_fixperms
dh_installdeb