summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndreas Loibl <andreas@andreas-loibl.de>2012-05-18 05:56:33 +0200
committerAndreas Loibl <andreas@andreas-loibl.de>2012-05-18 05:56:33 +0200
commitd18ec281cdcf2851180de54620206f394fda255e (patch)
tree323a5773652937eef705869e5bf29136cce72fa1 /debian
parente42c2f330d1a997433323977734a26d3ab99f755 (diff)
downloadetcskel-kanotix-d18ec281cdcf2851180de54620206f394fda255e.zip
etcskel-kanotix-d18ec281cdcf2851180de54620206f394fda255e.tar.gz
import changes from debian package version 2.0.0
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/copyright32
-rw-r--r--debian/kanotix-plasma-script.install6
-rw-r--r--debian/kanotix-plasma-script.postrm13
-rw-r--r--debian/kanotix-plasma-script.preinst31
-rw-r--r--debian/source.lintian-overrides6
-rw-r--r--debian/source/format1
7 files changed, 82 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index d0a3e6d..75c023a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+etcskel-kanotix (2.0.0) unstable; urgency=low
+
+ * first skeleton files for Kanotix Dragonfire
+ * updated Kanotix plasma desktop configuration
+ * disable screen lock after resume from suspend
+ * changed powerdevil critical battery level to 10%
+ * added new touchpad config and removed old configs
+ * added KDE default directories
+ * renew debian packaging to avoid lintian errors
+
+ -- Maximilian Gerhard <maxbox@directbox.com> Mon, 17 Mar 2012 22:11:40 +0100
+
etcskel-kanotix (1.1.5) unstable; urgency=low
* merged with acritox version
diff --git a/debian/copyright b/debian/copyright
index bf6f667..fffd808 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,25 +1,23 @@
This work was packaged for Debian by:
- Klaus Knopper <knoppix@knopper.net> on Fri, 1 Jun 2001 23:29:31 +0200
+ Maximilian Gerhard <maxbox@directbox.com> on Sat, 17 Mar 2012 22:39:49 +0100
-It was downloaded from:
+Upstream Authors:
- http://www.knopper.net/knoppix/
-
-Upstream Author(s):
-
- Klaus Knopper <knoppix@knopper.net>
+ Jörg Schirottke <master@kanotix.com>
+ Andreas Loibl <andreas@andreas-loibl.de>
+ Maximilian Gerhard <maxbox@directbox.com>
Copyright:
- Copyright (C) 2001 Klaus Knopper <knoppix@knopper.net>
+ initial etcskel packaging was made by Klaus Knopper (Knoppix)
License:
- This package is free software; you can redistribute it and/or modify
+ This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
+ the Free Software Foundation, either version 2 of the License, or
+ any later version.
This package is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -27,16 +25,16 @@ License:
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>
+ along with this program. If not, see http://www.gnu.org/licenses/gpl-2.0.html.
On Debian systems, the complete text of the GNU General
Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
The Debian packaging is:
- Copyright (C) 2001 Klaus Knopper <knoppix@knopper.net>
+ Copyright (C) 2012 Maximilian Gerhard <maxbox@directbox.com>
-you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation; either version 2 of the License, or
-(at your option) any later version.
+and is licensed under the GPL version 3.
+
+On Debian systems, the complete text of the GNU General
+Public License version 3 can be found in "/usr/share/common-licenses/GPL-3".
diff --git a/debian/kanotix-plasma-script.install b/debian/kanotix-plasma-script.install
index 2a76d4e..91fb47d 100644
--- a/debian/kanotix-plasma-script.install
+++ b/debian/kanotix-plasma-script.install
@@ -1,2 +1,4 @@
-plasma-desktop usr/share/kde4/apps/
-kanotix-reset-plasma-panel usr/bin
+kde-kanotix-settings usr/share/
+Xsession.d etc/X11/
+kanotix-reset-plasma-panel usr/bin/
+x-www-browser.desktop usr/share/applications/
diff --git a/debian/kanotix-plasma-script.postrm b/debian/kanotix-plasma-script.postrm
new file mode 100644
index 0000000..15dedd2
--- /dev/null
+++ b/debian/kanotix-plasma-script.postrm
@@ -0,0 +1,13 @@
+#!/bin/bash
+set -e
+
+remove_divert() {
+ diverter=$(dpkg-divert --listpackage $1)
+ if [ "$diverter" = "kanotix-plasma-script" ]; then
+ dpkg-divert --package kanotix-plasma-script --rename --remove $1
+ fi
+}
+
+if [ "$1" = remove ] || [ "$1" = deconfigure ]; then
+ remove_divert /usr/share/kde4/apps/plasma-desktop/init/00-defaultLayout.js
+fi
diff --git a/debian/kanotix-plasma-script.preinst b/debian/kanotix-plasma-script.preinst
new file mode 100644
index 0000000..5b97b24
--- /dev/null
+++ b/debian/kanotix-plasma-script.preinst
@@ -0,0 +1,31 @@
+#!/bin/bash
+set -e
+
+divert() {
+ dfile=$1
+ ltarget=$2
+ div=$(dpkg-divert --list $dfile)
+ distrib=${3:-$dfile.distrib}
+ temp=$dfile.tmp
+ if [ -z "$div" ]; then
+ # This differs from dpkg-divert's --rename because we
+ # first make a copy of $dfile (the file being diverted)
+ # in $distrib. Then, a symlink to $ltarget is forcibly created
+ # from $dfile; this is performed in two stages with an
+ # intermediate temporary file as ln -sf is not atomic.
+ # dpkg-divert's --rename direct equivalent would be:
+ # mv $dfile $distrib -- but we could end up without a symlink
+ if [ -e $dfile ]; then
+ cp -dp $dfile $distrib
+ fi
+ ln -sf $ltarget $temp
+ mv -f $temp $dfile
+ dpkg-divert --package kanotix-plasma-script --divert $distrib --add $dfile
+ fi
+}
+
+if [ install = "$1" -o upgrade = "$1" ]; then
+ # Divert the following files if no diversion exists already
+ divert /usr/share/kde4/apps/plasma-desktop/init/00-defaultLayout.js \
+ /usr/share/kde-kanotix-settings/share/apps/plasma-desktop/init/00-empty.js
+fi
diff --git a/debian/source.lintian-overrides b/debian/source.lintian-overrides
new file mode 100644
index 0000000..f99d7ed
--- /dev/null
+++ b/debian/source.lintian-overrides
@@ -0,0 +1,6 @@
+# we ignore ${Misc:Depends} because it's just configuration
+etcskel-kanotix source: debhelper-but-no-misc-depends user-profile-kanotix
+etcskel-kanotix source: debhelper-but-no-misc-depends badge-icon-kanotix
+etcskel-kanotix source: debhelper-but-no-misc-depends etcskel-kanotix-trinity
+etcskel-kanotix source: debhelper-but-no-misc-depends kanotix-plasma-script
+etcskel-kanotix source: debhelper-but-no-misc-depends etcskel-kanotix
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)