summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Paradies <retabell@gmx.de>2013-06-25 17:58:52 +0200
committerAndreas Loibl <andreas@andreas-loibl.de>2013-09-03 19:57:25 +0200
commit71621ce51dda25456645b903184c4f97d444abcd (patch)
tree33a503da5466b6c325c61840b4f4124a680851aa
parent692199c8f9d838175c007c4447dd0676f38b7ab0 (diff)
downloadkanotix-packages-71621ce51dda25456645b903184c4f97d444abcd.zip
kanotix-packages-71621ce51dda25456645b903184c4f97d444abcd.tar.gz
lxde-keyboard-switcher
-rw-r--r--kanotix-lxde-extra/debian/changelog6
-rwxr-xr-x[-rw-r--r--]kanotix-lxde-extra/kanotix-lxde-keyboard17
2 files changed, 19 insertions, 4 deletions
diff --git a/kanotix-lxde-extra/debian/changelog b/kanotix-lxde-extra/debian/changelog
index a2e195f..05f3ebe 100644
--- a/kanotix-lxde-extra/debian/changelog
+++ b/kanotix-lxde-extra/debian/changelog
@@ -1,3 +1,9 @@
+kanotix-lxde-extra (0.2.2update1) unstable; urgency=low
+
+ * keyboard-switcher from panel
+
+ -- Holger Paradies <retabell@gmx.de> Tue, 25 Jun 2013 17:57:00 +0200
+
kanotix-lxde-extra (0.2.2) unstable; urgency=low
* add lightdm upstart script
diff --git a/kanotix-lxde-extra/kanotix-lxde-keyboard b/kanotix-lxde-extra/kanotix-lxde-keyboard
index df30ace..8583213 100644..100755
--- a/kanotix-lxde-extra/kanotix-lxde-keyboard
+++ b/kanotix-lxde-extra/kanotix-lxde-keyboard
@@ -1,8 +1,17 @@
#!/bin/sh
# set default for lxde-keyboard-switcher
-setxkbmap -layout de,us,fr -variant nodeadkeys,,
-if grep 'XKBLAYOUT="us"' /etc/default/keyboard ;then
- setxkbmap -layout us,de,fr -variant ,nodeadkeys,
-fi
+XKBMODEL="pc105"
+XKBLAYOUT="ch"
+XKBVARIANT="nodeadkeys"
+XKBOPTIONS="terminate:ctrl_alt_bksp"
+BACKSPACE="guess"
+
+[ -f /etc/default/keyboard ] && . /etc/default/keyboard
+case $XKBLAYOUT in
+ de) setxkbmap -layout de,us,fr -variant nodeadkeys,, ;;
+ us) setxkbmap -layout us,fr,de -variant ,,nodeadkeys ;;
+ fr) setxkbmap -layout fr,de,us -variant ,nodeadkeys, ;;
+ *) setxkbmap -layout $XKBLAYOUT ;;
+esac