summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Paradies <retabell@gmx.de>2013-06-21 20:25:19 +0200
committerAndreas Loibl <andreas@andreas-loibl.de>2013-09-03 19:57:25 +0200
commitec306adff7b17bd49f6b50001b44699054ba80ef (patch)
tree89185878efaf9825e9cf82ed9b4b24f10b0cd7e9
parent4cded8443241ef62951580bd7619a8fbb7e87bb4 (diff)
downloadkanotix-packages-ec306adff7b17bd49f6b50001b44699054ba80ef.zip
kanotix-packages-ec306adff7b17bd49f6b50001b44699054ba80ef.tar.gz
Version 0.2.2
-rw-r--r--kanotix-lxde-extra/debian/changelog6
-rw-r--r--kanotix-lxde-extra/debian/install2
-rw-r--r--kanotix-lxde-extra/kanotix-lightdm-display-setup-script5
-rw-r--r--kanotix-lxde-extra/kanotix-lxde-upstart10
4 files changed, 23 insertions, 0 deletions
diff --git a/kanotix-lxde-extra/debian/changelog b/kanotix-lxde-extra/debian/changelog
index 588a499..a2e195f 100644
--- a/kanotix-lxde-extra/debian/changelog
+++ b/kanotix-lxde-extra/debian/changelog
@@ -1,3 +1,9 @@
+kanotix-lxde-extra (0.2.2) unstable; urgency=low
+
+ * add lightdm upstart script
+
+ -- Holger Paradies <retabell@gmx.de> Fri, 21 Jun 2013 20:22:10 +0200
+
kanotix-lxde-extra (0.2.1) dragonfire; urgency=low
* new Version Scheme
diff --git a/kanotix-lxde-extra/debian/install b/kanotix-lxde-extra/debian/install
index 556ba2a..0f6082b 100644
--- a/kanotix-lxde-extra/debian/install
+++ b/kanotix-lxde-extra/debian/install
@@ -3,3 +3,5 @@ splash_background_dragonfire.png usr/share/images/kanotix-lxde
kanotix-start-compiz usr/bin
51-synaptics-kanotix.conf usr/share/X11/xorg.conf.d
kanotix-eject.desktop usr/share/applications
+kanotix-lxde-upstart usr/sbin
+kanotix-lightdm-display-setup-script usr/sbin \ No newline at end of file
diff --git a/kanotix-lxde-extra/kanotix-lightdm-display-setup-script b/kanotix-lxde-extra/kanotix-lightdm-display-setup-script
new file mode 100644
index 0000000..0140fa8
--- /dev/null
+++ b/kanotix-lxde-extra/kanotix-lightdm-display-setup-script
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+# do not delete this file, or lightdm won't start, it is called by lightdm
+/usr/sbin/kanotix-lxde-upstart &
+exit 0
diff --git a/kanotix-lxde-extra/kanotix-lxde-upstart b/kanotix-lxde-extra/kanotix-lxde-upstart
new file mode 100644
index 0000000..ec5dcb5
--- /dev/null
+++ b/kanotix-lxde-extra/kanotix-lxde-upstart
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# generate icon-cache deleted in live-build
+if ! [ -e /usr/share/icons/nuoveXT2/icon-theme.cache ]; then
+find /usr/share/icons -mindepth 1 -maxdepth 1 -type d | while read -r ICON; do
+if [ -f "$ICON/index.theme" ]; then
+ gtk-update-icon-cache-3.0 -f -q "$ICON"
+fi
+done
+fi