summaryrefslogtreecommitdiff
path: root/kanotix-irc
diff options
context:
space:
mode:
authorHolger Paradies <retabell@gmx.de>2013-12-24 10:19:14 +0100
committerHolger Paradies <retabell@gmx.de>2014-01-04 16:01:05 +0100
commitd48660411e26c18fb76fa0c83a89f8e2710fe926 (patch)
tree879045ef9ce678a04c5ca96fac174015f183866c /kanotix-irc
parent0e66b833868a6a8530045db9002c1845f242e4ac (diff)
downloadkanotix-packages-d48660411e26c18fb76fa0c83a89f8e2710fe926.zip
kanotix-packages-d48660411e26c18fb76fa0c83a89f8e2710fe926.tar.gz
kanotix-irc-1.0.1
Diffstat (limited to 'kanotix-irc')
-rw-r--r--kanotix-irc/debian/changelog6
-rwxr-xr-xkanotix-irc/kanotix-irc31
-rw-r--r--kanotix-irc/skel/.xchat2/commands.conf2
-rw-r--r--kanotix-irc/skel/.xchat2/xchat.conf8
4 files changed, 38 insertions, 9 deletions
diff --git a/kanotix-irc/debian/changelog b/kanotix-irc/debian/changelog
index 77f3886..c4b0cd0 100644
--- a/kanotix-irc/debian/changelog
+++ b/kanotix-irc/debian/changelog
@@ -1,3 +1,9 @@
+kanotix-irc (1.0.1) unstable; urgency=low
+
+ * add small xchat2 preconfig and combine with tmp config
+
+ -- Holger Paradies <retabell@gmx.de> Tue, 26 Feb 2013 13:32:44 +0100
+
kanotix-irc (1.0.0) unstable; urgency=low
* Zenity support added by Jörg Schirottke <master@kanotix.com>
diff --git a/kanotix-irc/kanotix-irc b/kanotix-irc/kanotix-irc
index a3afd32..cd23d0c 100755
--- a/kanotix-irc/kanotix-irc
+++ b/kanotix-irc/kanotix-irc
@@ -329,6 +329,28 @@ kanotix_xchat()
{
XCHATCFG="$($MKTEMP -dp /tmp/ .xchat2-XXXXXXXXXX)"
+ if [ -e ~/.xchat2/ ]; then
+ cp -r ~/.xchat2/* "$XCHATCFG/"
+ # delete improper lines
+ sed -i '/gui_join_dialog/d;
+ /gui_slist_skip/d;
+ /gui_slist_select/d;
+ /irc_nick1/d;
+ /irc_nick2/d;
+ /irc_nick3/d;
+ /irc_user_name/d;
+ /irc_real_name/d' "$XCHATCFG/xchat.conf"
+ fi
+ cat <<_EOF_ >>"$XCHATCFG/xchat.conf"
+gui_join_dialog = 0
+gui_slist_select = 0
+gui_slist_skip = 1
+irc_nick1 = $NICK
+irc_nick2 = ${NICK}_
+irc_nick3 = ${NICK}__
+_EOF_
+
+
cat <<_EOF_ >"$XCHATCFG/servlist_.conf"
N=FreeNode
J=#kanotix
@@ -350,15 +372,6 @@ S=irc.freenode.net/$FLL_IRC_PORT
S=irc.freenode.net/+7000
_EOF_
- cat <<_EOF_ >"$XCHATCFG/xchat.conf"
-gui_join_dialog = 0
-gui_slist_select = 0
-gui_slist_skip = 1
-irc_nick1 = $NICK
-irc_nick2 = ${NICK}_
-irc_nick3 = ${NICK}__
-_EOF_
-
cat <<_EOF_ >"$XCHATCFG/commands.conf"
NAME cmd
CMD exec -o &2
diff --git a/kanotix-irc/skel/.xchat2/commands.conf b/kanotix-irc/skel/.xchat2/commands.conf
new file mode 100644
index 0000000..dbdd1f1
--- /dev/null
+++ b/kanotix-irc/skel/.xchat2/commands.conf
@@ -0,0 +1,2 @@
+NAME cmd
+CMD exec -o &2
diff --git a/kanotix-irc/skel/.xchat2/xchat.conf b/kanotix-irc/skel/.xchat2/xchat.conf
new file mode 100644
index 0000000..ef423bc
--- /dev/null
+++ b/kanotix-irc/skel/.xchat2/xchat.conf
@@ -0,0 +1,8 @@
+version = 2.8.8
+completion_sort = 1
+gui_input_spell = 0
+stamp_text = 1
+tab_layout = 0
+tab_pos = 6
+text_font = Monospace 12
+text_show_marker = 0