summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2007-09-23 10:04:46 +0200
committerDaniel Baumann <daniel@debian.org>2011-03-09 18:14:51 +0100
commitfe6eb1c593e2df135c8807bf94df614984b4d6ec (patch)
tree693b803dcc6473a8699f0c605c92b10c24755e28 /debian/rules
parent470cf1764bf56b32addff591cfe3fd69af0e5760 (diff)
downloadlive-build-fe6eb1c593e2df135c8807bf94df614984b4d6ec.zip
live-build-fe6eb1c593e2df135c8807bf94df614984b4d6ec.tar.gz
Adding live-helper 1.0~a1-1.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 11 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index ef72dea..1d9b92c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,8 +3,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-upstream: # Needs svn
- cd .. && svn co svn://svn.debian.org/debian-live/dists/trunk/live-package || exit 0
+upstream:
+ # Needs: subversion
+ cd .. && svn co svn://svn.debian.org/debian-live/dists/trunk/live-helper || exit 0
find . -type d -name .svn -exec rm -rf {} \; || exit 0
build:
@@ -22,18 +23,22 @@ install: build
dh_installdirs
# Installing package
- $(MAKE) install DESTDIR=$(CURDIR)/debian/live-package
- install -D debian/default debian/live-package/etc/default/make-live
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper
+
+ # Removing double files
+ rm -f debian/live-helper/usr/share/doc/live-helper/COPYING
+ rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
+ mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.old \
+ debian/live-helper/usr/share/doc/live-helper/changelog.old
binary-arch: build install
binary-indep: build install
dh_testdir
dh_testroot
- dh_installchangelogs ChangeLog
+ dh_installchangelogs doc/ChangeLog
dh_installdocs
dh_install
- dh_installcron
dh_compress
dh_fixperms
dh_installdeb