summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2010-01-19 22:12:36 +0100
committerDaniel Baumann <daniel@debian.org>2011-03-09 19:17:03 +0100
commit44a580e8f9ed3c33bad9c81b4839e4495ad364b0 (patch)
tree5cf492dffadf9a7048fc03410b6db4df61af3bc2 /debian
parent06e36c3b52b9573ff546080f6d5ab9d4566d412d (diff)
downloadlive-build-44a580e8f9ed3c33bad9c81b4839e4495ad364b0.zip
live-build-44a580e8f9ed3c33bad9c81b4839e4495ad364b0.tar.gz
Minimizing rules file.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/live-helper.bug-presubj (renamed from debian/bug/live-helper.presubj)0
-rw-r--r--debian/live-helper.bug-script (renamed from debian/bug/live-helper.script)0
-rwxr-xr-xdebian/rules45
4 files changed, 8 insertions, 39 deletions
diff --git a/debian/control b/debian/control
index 2871a69..e97d8c1 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: misc
Priority: optional
Maintainer: Debian Live <debian-live@lists.debian.org>
Uploaders: Daniel Baumann <daniel@debian.org>
-Build-Depends: debhelper (>= 7)
+Build-Depends: debhelper (>= 7.0.50~)
Build-Depends-Indep: gettext
Standards-Version: 3.8.3
Homepage: http://debian-live.alioth.debian.org/
diff --git a/debian/bug/live-helper.presubj b/debian/live-helper.bug-presubj
index e59a93a..e59a93a 100644
--- a/debian/bug/live-helper.presubj
+++ b/debian/live-helper.bug-presubj
diff --git a/debian/bug/live-helper.script b/debian/live-helper.bug-script
index 54ef8dd..54ef8dd 100644
--- a/debian/bug/live-helper.script
+++ b/debian/live-helper.bug-script
diff --git a/debian/rules b/debian/rules
index 4b7ce63..c9fd0ff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,27 +1,17 @@
#!/usr/bin/make -f
-clean:
- dh_testdir
- dh_testroot
+%:
+ dh ${@}
+override_dh_auto_clean:
$(MAKE) -C po clean
- dh_clean
-
-build:
- $(MAKE) test
+override_dh_auto_build:
$(MAKE) -C po update-po
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- # Installing package
- $(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper
+override_dh_auto_install:
+ dh_auto_install
- # Installing message catalogs
$(MAKE) -C po install DESTDIR=$(CURDIR)/debian/live-helper
install -D -m 0644 debian/live-helper.default debian/live-helper/etc/default/live-helper_autobuild
@@ -35,27 +25,6 @@ install: build
rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.live-package
- # Installing bug control
- install -D -m 0644 debian/bug/live-helper.presubj debian/live-helper/usr/share/bug/live-helper/presubj
- install -D -m 0755 debian/bug/live-helper.script debian/live-helper/usr/share/bug/live-helper/script
-
-binary: binary-indep
-
-binary-arch:
-binary-indep: install
- dh_testdir
- dh_testroot
+override_dh_installchangelogs:
dh_installchangelogs docs/ChangeLog
- dh_installdocs
- dh_installlogrotate
- dh_installcron
- dh_installman
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-.PHONY: clean build install binary binary-arch binary-indep