summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2010-07-24 16:18:02 +0200
committerDaniel Baumann <daniel@debian.org>2011-03-09 19:17:15 +0100
commitc58e77942a264198c8bf00c96413968cffea8d4f (patch)
treea0f73c921c1dda6d6a3d49d923815b8de9a7afae /debian
parent79b6f784534bb01b30c86992094c88f6ce757880 (diff)
downloadlive-build-c58e77942a264198c8bf00c96413968cffea8d4f.zip
live-build-c58e77942a264198c8bf00c96413968cffea8d4f.tar.gz
Splitting out cgi frontend to own package.
Diffstat (limited to 'debian')
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules15
2 files changed, 20 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 7c67a1f..11c52f7 100644
--- a/debian/control
+++ b/debian/control
@@ -28,6 +28,17 @@ Description: Debian Live - System Build Scripts
.
An introduction to live-build can be found in the live-build(7) manpage.
+Package: live-build-cgi
+Architecture: all
+Depends: ${misc:Depends}, live-helper (= ${source:Version})
+Conflicts: live-helper (<< 2.0~a20)
+Replaces: live-helper
+Recommends: apache2 | httpd
+Description: Debian Live - System Build Scripts (cgi frontend)
+ live-build is a set of scripts to build Debian Live system images.
+ .
+ This package contains the cgi frontend.
+
Package: live-helper
Architecture: all
Depends: ${misc:Depends}, live-helper
diff --git a/debian/rules b/debian/rules
index 7e5ae5a..36aab04 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,15 +10,18 @@ override_dh_auto_build:
$(MAKE) -C po update-po
override_dh_auto_install:
- dh_auto_install
-
+ $(MAKE) DESTDIR=$(CURDIR)/debian/live-build install
$(MAKE) -C po DESTDIR=$(CURDIR)/debian/live-build install
- mv debian/live-build/usr/share/doc/live-build/ChangeLog.live-package debian/live-build/usr/share/doc/live-build/changelog.live-package
- mv debian/live-build/usr/share/doc/live-build/ChangeLog.live-webhelper debian/live-build/usr/share/doc/live-build/changelog.live-webhelper
+ mv debian/live-build/usr/share/doc/live-helper/ChangeLog.live-package debian/live-build/usr/share/doc/live-helper/changelog.live-package
+ mv debian/live-build/usr/share/doc/live-helper/ChangeLog.live-webhelper debian/live-build/usr/share/doc/live-helper/changelog.live-webhelper
+
+ rm -f debian/live-build/usr/share/doc/live-helper/COPYING
+ rm -f debian/live-build/usr/share/doc/live-helper/ChangeLog
- rm -f debian/live-build/usr/share/doc/live-build/COPYING
- rm -f debian/live-build/usr/share/doc/live-build/ChangeLog
+ # live-buld-cgi
+ mkdir -p debian/live-build-cgi/usr/share/live-helper
+ mv debian/live-build/usr/share/live-helper/cgi debian/live-build-cgi/usr/share/live-helper
override_dh_installchangelogs:
dh_installchangelogs docs/ChangeLog