summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2007-09-23 10:04:20 +0200
committerDaniel Baumann <daniel@debian.org>2007-09-23 10:04:20 +0200
commiteeaafbe5c0d5f2ffd87bf7d9f12c13df1bd0adf5 (patch)
tree18151396add367542887fe7f017025538e3318d6 /debian
downloadlive-build-eeaafbe5c0d5f2ffd87bf7d9f12c13df1bd0adf5.zip
live-build-eeaafbe5c0d5f2ffd87bf7d9f12c13df1bd0adf5.tar.gz
Adding live-package 0.99-1.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control14
-rw-r--r--debian/copyright57
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules43
6 files changed, 121 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ac449b8
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+live-package (0.99-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 17 Jul 2006 00:00:00 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5859b97
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: live-package
+Section: misc
+Priority: optional
+Maintainer: Daniel Baumann <daniel@debian.org>
+Uploaders: Marco Amadori <marco.amadori@gmail.com>
+Build-Depends: debhelper (>= 4)
+Standards-Version: 3.7.2
+
+Package: live-package
+Architecture: all
+Depends: cdebootstrap (>= 0.3.10) | debootstrap (>= 3.3), dpkg-dev, genext2fs, mkisofs, squashfs-tools
+Provides: make-live
+Description: Debian Live framework
+ The Debian Live framework lets you automagically create live system images.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..17cbf08
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,57 @@
+This package was debianized by Daniel Baumann <daniel@debian.org> on
+Mon, 17 Jul 2006 00:00:00 +0200.
+
+It was downloaded from <http://live.debian.net/>.
+
+Copyright Holders: Daniel Baumann <daniel@debian.org>,
+ Marco Amadori <marco.amadori@gmail.com>.
+
+License:
+
+ Copyright (C) 2006 Daniel Baumann <daniel@debian.org>
+ Copyright (C) 2006 Marco Amadori <marco.amadori@gmail.com>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL file.
+
+License (contrib/syslinux-splash/*, templates/isolinux/splash.rle):
+
+ The derivated splash for Debian Live was done by Daniel Baumann
+ <daniel@debian.org> from the original of Mark Riedesel. Daniels own
+ contribution to the derivated splash is hereby placed in the public
+ domain.
+
+ ---------------
+ http://dugnet.com/klown/pics/klowner_debboot.png
+ by Mark Riedesel, license same as open use logo
+
+ To create klowner.rle:
+
+ 1. convert klowner.png klowner.bmp
+ 2. bmptoppm < klowner.bmp | ppmtolss16 #FBFDFA=7 > klowner.rle
+
+ (FBFDFA is the color used for the inside of the "n" in Debian.)
+ ---------------
+
+ Debian Open Use Logo License
+
+ Copyright (c) 1999 Software in the Public Interest
+ This logo or a modified version may be used by anyone to refer to the
+ Debian project, but does not indicate endorsement by the project.
+
+ Note: we would appreciate that you make the image a link to
+ http://www.debian.org/ if you use it on a web page.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..62deb04
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+AUTHORS
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e47f520
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+upstream:
+ cd .. && svn co svn://live.debian.net/live-package || exit 0
+ find . -type d -name .svn -exec rm -rf {} \; || exit 0
+
+build:
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Installing package
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/live-package
+
+binary-arch: build install
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_install
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install