summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/cron.daily12
-rw-r--r--debian/default2
3 files changed, 18 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 4b0e256..a7328a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+live-helper (1.0~a22-1) unstable; urgency=medium
+
+ * New upstream release:
+ - Replacing make-live with lh_config and lh_build (Closes: #435484).
+ - Added workaround from matth in lh_binary_grub, lh_binary_syslinux and
+ lh_binary_yaboot to work under dash (Closes: #431748).
+ - Using fake hostname instead of setting it at build-time (Closes: #435699).
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 6 Aug 2007 00:00:00 +0200
+
live-helper (1.0~a21-1) unstable; urgency=medium
* New upstream release:
diff --git a/debian/cron.daily b/debian/cron.daily
index a8c139f..a5febe5 100644
--- a/debian/cron.daily
+++ b/debian/cron.daily
@@ -5,7 +5,7 @@ set -e
BUILD="daily"
# Checking for live-helper availability
-if [ ! -x /usr/bin/make-live ]
+if [ ! -x /usr/bin/lh_config ]
then
exit 0
fi
@@ -48,11 +48,12 @@ do
# Creating build directory
mkdir -p "${TEMPDIR}"/debian-live
- cd "${TEMPDIR}"
+ cd "${TEMPDIR}"/debian-live
echo "Begin: `date -R`" > "${TEMPDIR}"/debian-live/log.txt
# Generating images
- make-live -b iso -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source enabled ${OPTIONS} >> "${TEMPDIR}"/debian-live/log.txt 2>&1
+ lh_config -b iso -s tar --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source enabled ${OPTIONS}
+ lh_build >> "${TEMPDIR}"/debian-live/log.txt 2>&1
echo "End: `date -R`" >> "${TEMPDIR}"/debian-live/log.txt
fi
@@ -88,11 +89,12 @@ do
# Creating build directory
mkdir -p "${TEMPDIR}"/debian-live
- cd "${TEMPDIR}"
+ cd "${TEMPDIR}"/debian-live
echo "Begin: `date -R`" > "${TEMPDIR}"/debian-live/log.txt
# Generating images
- make-live -b usb-hdd -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source disabled ${OPTIONS} >> "${TEMPDIR}"/debian-live/log.txt 2>&1
+ lh_config -b usb-hdd -s tar --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source disabled ${OPTIONS}
+ lh_build >> "${TEMPDIR}"/debian-live/log.txt 2>&1
echo "End: `date -R`" >> "${TEMPDIR}"/debian-live/log.txt
fi
diff --git a/debian/default b/debian/default
index 8aebe5a..0ca9a27 100644
--- a/debian/default
+++ b/debian/default
@@ -14,4 +14,4 @@ MIRROR_BOOTSTRAP="http://ftp.debian.org/debian/"
MIRROR_BOOTSTRAP_SECURITY="http://security.debian.org/"
MIRROR_BINARY="http://ftp.debian.org/debian/"
MIRROR_BINARY_SECURITY="http://security.debian.org/"
-PACKAGES_LISTS="standard gnome-desktop kde-desktop xfce-desktop"
+PACKAGES_LISTS="standard rescue gnome-desktop kde-desktop xfce-desktop"