summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control1
-rw-r--r--debian/cron.daily182
-rw-r--r--debian/default20
-rw-r--r--debian/postrm25
-rw-r--r--debian/preinst25
-rwxr-xr-xdebian/rules2
7 files changed, 119 insertions, 143 deletions
diff --git a/debian/changelog b/debian/changelog
index 5c84dd1..d9ac447 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+live-helper (1.0~a10-1) unstable; urgency=medium
+
+ * New upstream release:
+ - really removed forgotten set -x in the cron (Closes: #421105).
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 14 May 2007 00:00:00 +0200
+
live-helper (1.0~a9-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 88cd721..2e2aac1 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Uploaders: Daniel Baumann <daniel@debian.org>, Marco Amadori <marco.amadori@gmai
Build-Depends: debhelper (>= 5)
Standards-Version: 3.7.2
XS-Vcs-Svn: svn://svn.debian.org/debian-live/dists/trunk/live-helper/
+XS-VCS-Browse: http://svn.debian.org/wsvn/debian-live/dists/trunk/live-helper/
Package: live-helper
Architecture: all
diff --git a/debian/cron.daily b/debian/cron.daily
index 633cc25..f7e205b 100644
--- a/debian/cron.daily
+++ b/debian/cron.daily
@@ -1,16 +1,16 @@
-#!/bin/sh -x
+#!/bin/sh
set -e
BUILD="daily"
-# Check for live-helper availability
+# Checking for live-helper availability
if [ ! -x /usr/bin/make-live ]
then
exit 0
fi
-# Check for live-helper defaults
+# Checking for live-helper defaults
if [ -r /etc/default/live-helper ]
then
. /etc/default/live-helper
@@ -19,114 +19,130 @@ else
exit 1
fi
-# Check for autobuild
+# Checking for autobuild
if [ "${AUTOBUILD}" != "enabled" ]
then
exit 0
fi
-# Check for build directory
-if [ ! -d "${AUTOBUILD_TEMPDIR}" ]
+# Checking for build directory
+if [ ! -d "${TEMPDIR}" ]
then
- mkdir -p "${AUTOBUILD_TEMPDIR}"/debian-live
+ mkdir -p "${TEMPDIR}"/debian-live
else
# FIXME: maybe we should just remove the left overs.
- echo "E: ${AUTOBUILD_TEMPDIR} needs cleanup."
+ echo "E: ${TEMPDIR} needs cleanup."
exit 1
fi
-for ARCHITECTURE in ${AUTOBUILD_ARCHITECTURES}
+for ARCHITECTURE in ${ARCHITECTURES}
do
- for DISTRIBUTION in ${AUTOBUILD_DISTRIBUTIONS}
+ for DISTRIBUTION in ${DISTRIBUTIONS}
do
- for PACKAGES_LIST in ${AUTOBUILD_PACKAGES_LISTS}
+ for PACKAGES_LIST in ${PACKAGES_LISTS}
do
- if [ ! -f "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-iso-log.txt ]
- then
- # Generating images
- mkdir -p "${AUTOBUILD_TEMPDIR}"/debian-live
- cd "${AUTOBUILD_TEMPDIR}"
- echo "Begin: `date -R`" > "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt
- make-live -b iso -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-build ${AUTOBUILD_MIRROR} --mirror-build-security ${AUTOBUILD_MIRROR_SECURITY} --source enabled ${AUTOBUILD_OPTIONS} >> "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt 2>&1
- echo "End: `date -R`" >> "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt
- fi
-
- if [ -f "${AUTOBUILD_TEMPDIR}"/debian-live/binary.iso ] && [ -f "${AUTOBUILD_TEMPDIR}"/debian-live/source.tar ]
- then
- # Moving logs
- mkdir -p "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-iso-log.txt
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/packages.txt "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-iso-packages.txt
-
- # Moving images
- mkdir -p "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/${ARCHITECTURE}
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/binary.iso "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/${ARCHITECTURE}/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}.iso
-
- mkdir -p "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/source
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/source.tar "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/source/debian-live-${DISTRIBUTION}-source-${PACKAGES_LIST}.tar
- fi
-
- if [ ! -f "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-usb-log.txt ]
- then
- # Workaround of missing multi-binary support in live-helper
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/binary/casper "${AUTOBUILD_TEMPDIR}"/debian-live/casper.tmp
- rm -rf "${AUTOBUILD_TEMPDIR}"/debian-live/binary* "${AUTOBUILD_TEMPDIR}"/debian-live/.stage/binary_*
- mkdir "${AUTOBUILD_TEMPDIR}"/debian-live/binary
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/casper.tmp "${AUTOBUILD_TEMPDIR}"/debian-live/binary/casper
- touch "${AUTOBUILD_TEMPDIR}"/debian-live/.stage/binary_chroot
- touch "${AUTOBUILD_TEMPDIR}"/debian-live/.stage/binary_rootfs
-
- # Generating images
- mkdir -p "${AUTOBUILD_TEMPDIR}"/debian-live
- cd "${AUTOBUILD_TEMPDIR}"
- echo "Begin: `date -R`" > "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt
- make-live -b usb -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-build ${AUTOBUILD_MIRROR} --mirror-build-security ${AUTOBUILD_MIRROR_SECURITY} --source disabled ${AUTOBUILD_OPTIONS} >> "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt 2>&1
- echo "End: `date -R`" >> "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt
- fi
-
- if [ -f "${AUTOBUILD_TEMPDIR}"/debian-live/binary.img ]
- then
- # Moving logs
- mkdir -p "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/log.txt "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-usb-log.txt
- cp "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-iso-packages.txt "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${AUTOBUILD_DATE}-usb-packages.txt
-
- # Moving images
- mkdir -p "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/${ARCHITECTURE}
- mv "${AUTOBUILD_TEMPDIR}"/debian-live/binary.img "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/${ARCHITECTURE}/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}.img
- fi
-
- # Cleanup
- cd "${AUTOBUILD_TEMPDIR}"/debian-live
- lh_clean
+ if [ ! -f "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-iso-log.txt ]
+ then
+ # Creating build directory
+ mkdir -p "${TEMPDIR}"/debian-live
+
+ cd "${TEMPDIR}"
+ echo "Begin: `date -R`" > "${TEMPDIR}"/debian-live/log.txt
+
+ # Generating images
+ make-live -b iso -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source enabled ${OPTIONS} >> "${TEMPDIR}"/debian-live/log.txt 2>&1
+
+ echo "End: `date -R`" >> "${TEMPDIR}"/debian-live/log.txt
+ fi
+
+ if [ -f "${TEMPDIR}"/debian-live/binary.iso ] && [ -f "${TEMPDIR}"/debian-live/source.tar ]
+ then
+ # Creating log directory
+ mkdir -p "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log
+
+ # Moving logs
+ mv "${TEMPDIR}"/debian-live/log.txt "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-iso-log.txt
+ mv "${TEMPDIR}"/debian-live/packages.txt "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-iso-packages.txt
+
+ # Creating images directory
+ mkdir -p "${DESTDIR}"/"${BUILD}"-builds/${DATE}/${ARCHITECTURE}
+ mkdir -p "${DESTDIR}"/"${BUILD}"-builds/${DATE}/source
+
+ # Moving images
+ mv "${TEMPDIR}"/debian-live/binary.iso "${DESTDIR}"/"${BUILD}"-builds/${DATE}/${ARCHITECTURE}/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}.iso
+ mv "${TEMPDIR}"/debian-live/source.tar "${DESTDIR}"/"${BUILD}"-builds/${DATE}/source/debian-live-${DISTRIBUTION}-source-${PACKAGES_LIST}.tar
+ fi
+
+ if [ ! -f "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-usb-hdd-log.txt ]
+ then
+ # Workaround of missing multi-binary support in live-helper
+ mv "${TEMPDIR}"/debian-live/binary/casper "${TEMPDIR}"/debian-live/casper.tmp
+ rm -rf "${TEMPDIR}"/debian-live/binary* "${TEMPDIR}"/debian-live/.stage/binary_*
+ mkdir "${TEMPDIR}"/debian-live/binary
+ mv "${TEMPDIR}"/debian-live/casper.tmp "${TEMPDIR}"/debian-live/binary/casper
+ touch "${TEMPDIR}"/debian-live/.stage/binary_chroot
+ touch "${TEMPDIR}"/debian-live/.stage/binary_rootfs
+
+ # Creating build directory
+ mkdir -p "${TEMPDIR}"/debian-live
+
+ cd "${TEMPDIR}"
+ echo "Begin: `date -R`" > "${TEMPDIR}"/debian-live/log.txt
+
+ # Generating images
+ make-live -b usb-hdd -s generic --distribution ${DISTRIBUTION} --packages-lists ${PACKAGES_LIST} --mirror-bootstrap ${MIRROR_BOOTSTRAP} --mirror-bootstrap-security ${MIRROR_BOOTSTRAP_SECURITY} --mirror-binary ${MIRROR_BINARY} --mirror-binary-security ${MIRROR_BINARY_SECURITY} --source disabled ${OPTIONS} >> "${TEMPDIR}"/debian-live/log.txt 2>&1
+
+ echo "End: `date -R`" >> "${TEMPDIR}"/debian-live/log.txt
+ fi
+
+ if [ -f "${TEMPDIR}"/debian-live/binary.img ]
+ then
+ # Creating log directory
+ mkdir -p "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log
+
+ # Moving logs
+ mv "${TEMPDIR}"/debian-live/log.txt "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-usb-hdd-log.txt
+ cp "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-iso-packages.txt "${DESTDIR}"/"${BUILD}"-builds/${DATE}/log/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}_${DATE}-usb-hdd-packages.txt
+
+ # Creating image directory
+ mkdir -p "${DESTDIR}"/"${BUILD}"-builds/${DATE}/${ARCHITECTURE}
+
+ # Moving images
+ mv "${TEMPDIR}"/debian-live/binary.img "${DESTDIR}"/"${BUILD}"-builds/${DATE}/${ARCHITECTURE}/debian-live-${DISTRIBUTION}-${ARCHITECTURE}-${PACKAGES_LIST}.img
+ fi
+
+ # Cleanup
+ cd "${TEMPDIR}"/debian-live
+ lh_clean
done
- # Cleanup
- cd "${AUTOBUILD_TEMPDIR}"/debian-live
- lh_clean purge
+ # Cleanup
+ cd "${TEMPDIR}"/debian-live
+ lh_clean purge
done
done
-# Cleanup
-if [ -e "${AUTOBUILD_TEMPDIR}"/debian-live/chroot/proc/version ]
+# Cleaning up
+if [ -f "${TEMPDIR}"/debian-live/chroot/proc/version ]
then
- umount "${AUTOBUILD_TEMPDIR}"/debian-live/chroot/proc
+ umount "${TEMPDIR}"/debian-live/chroot/proc
fi
-if [ -d "${AUTOBUILD_TEMPDIR}"/debian-live/chroot/sys/kernel ]
+if [ -d "${TEMPDIR}"/debian-live/chroot/sys/kernel ]
then
- umount "${AUTOBUILD_TEMPDIR}"/debian-live/chroot/sys
+ umount "${TEMPDIR}"/debian-live/chroot/sys
fi
-rm -rf "${AUTOBUILD_TEMPDIR}"
+# Removing build directory
+rm -rf "${TEMPDIR}"
-# md5sums
-for DIRECTORY in "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/${AUTOBUILD_DATE}/*
+# Creating md5sums
+for DIRECTORY in "${DESTDIR}"/"${BUILD}"-builds/${DATE}/*
do
cd "${DIRECTORY}"
md5sum * > MD5SUMS
done
-# Current symlink
-rm -f "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/current
-ln -s ${AUTOBUILD_DATE} "${AUTOBUILD_DESTDIR}"/"${BUILD}"-builds/current
+# Creating current symlink
+rm -f "${DESTDIR}"/"${BUILD}"-builds/current
+ln -s ${DATE} "${DESTDIR}"/"${BUILD}"-builds/current
diff --git a/debian/default b/debian/default
index 5d26a72..8aebe5a 100644
--- a/debian/default
+++ b/debian/default
@@ -2,14 +2,16 @@
AUTOBUILD="disabled"
-AUTOBUILD_ARCHITECTURES="`dpkg --print-architecture`"
-AUTOBUILD_DISTRIBUTIONS="sid"
-AUTOBUILD_PACKAGES_LISTS="standard gnome-desktop kde-desktop xfce-desktop"
-AUTOBUILD_OPTIONS="--apt-recommends disabled"
+DATE="`date +%Y%m%d`"
+DESTDIR="/srv/debian-live"
+TEMPDIR="/srv/tmp/live-helper"
-AUTOBUILD_DATE="`date +%Y%m%d`"
-AUTOBUILD_DESTDIR="/srv/debian-live"
-AUTOBUILD_TEMPDIR="/srv/tmp"
+OPTIONS="--binary-indices disabled"
-AUTOBUILD_MIRROR="http://ftp.debian.org/debian/"
-AUTOBUILD_MIRROR_SECURITY="http://security.debian.org/"
+ARCHITECTURES="`dpkg --print-architecture`"
+DISTRIBUTIONS="sid"
+MIRROR_BOOTSTRAP="http://ftp.debian.org/debian/"
+MIRROR_BOOTSTRAP_SECURITY="http://security.debian.org/"
+MIRROR_BINARY="http://ftp.debian.org/debian/"
+MIRROR_BINARY_SECURITY="http://security.debian.org/"
+PACKAGES_LISTS="standard gnome-desktop kde-desktop xfce-desktop"
diff --git a/debian/postrm b/debian/postrm
deleted file mode 100644
index 08e1cb3..0000000
--- a/debian/postrm
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-set -e
-
-case "${1}" in
- remove)
- for FILE in /usr/share/man/man7/casper.7.gz /usr/share/man/man1/casper-snapshot.1.gz
- do
- dpkg-divert --package live-helper --remove --rename --divert ${FILE}.casper ${FILE}
- done
- ;;
-
- purge|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
-
- ;;
-
- *)
- echo "postrm called with unknown argument \`${1}'" >&2
- exit 1
- ;;
-esac
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/preinst b/debian/preinst
deleted file mode 100644
index 6ea28e5..0000000
--- a/debian/preinst
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-set -e
-
-case "${1}" in
- install)
- for FILE in /usr/share/man/man7/casper.7.gz /usr/share/man/man1/casper-snapshot.1.gz
- do
- dpkg-divert --package live-helper --add --rename --divert ${FILE}.casper ${FILE}
- done
- ;;
-
- upgrade|abort-upgrade)
-
- ;;
-
- *)
- echo "preinst called with unknown argument \`${1}'" >&2
- exit 1
- ;;
-esac
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/rules b/debian/rules
index 687cd3c..a635706 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,7 +39,7 @@ binary-arch: build install
binary-indep: build install
dh_testdir
dh_testroot
- dh_installchangelogs doc/ChangeLog
+ dh_installchangelogs docs/ChangeLog
dh_installdocs
dh_install
dh_installcron