summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2010-01-19 22:12:36 +0100
committerDaniel Baumann <daniel@debian.org>2011-03-09 19:17:03 +0100
commit44a580e8f9ed3c33bad9c81b4839e4495ad364b0 (patch)
tree5cf492dffadf9a7048fc03410b6db4df61af3bc2 /debian/rules
parent06e36c3b52b9573ff546080f6d5ab9d4566d412d (diff)
downloadlive-build-44a580e8f9ed3c33bad9c81b4839e4495ad364b0.zip
live-build-44a580e8f9ed3c33bad9c81b4839e4495ad364b0.tar.gz
Minimizing rules file.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules45
1 files changed, 7 insertions, 38 deletions
diff --git a/debian/rules b/debian/rules
index 4b7ce63..c9fd0ff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,27 +1,17 @@
#!/usr/bin/make -f
-clean:
- dh_testdir
- dh_testroot
+%:
+ dh ${@}
+override_dh_auto_clean:
$(MAKE) -C po clean
- dh_clean
-
-build:
- $(MAKE) test
+override_dh_auto_build:
$(MAKE) -C po update-po
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- # Installing package
- $(MAKE) install DESTDIR=$(CURDIR)/debian/live-helper
+override_dh_auto_install:
+ dh_auto_install
- # Installing message catalogs
$(MAKE) -C po install DESTDIR=$(CURDIR)/debian/live-helper
install -D -m 0644 debian/live-helper.default debian/live-helper/etc/default/live-helper_autobuild
@@ -35,27 +25,6 @@ install: build
rm -f debian/live-helper/usr/share/doc/live-helper/ChangeLog
mv debian/live-helper/usr/share/doc/live-helper/ChangeLog.live-package debian/live-helper/usr/share/doc/live-helper/changelog.live-package
- # Installing bug control
- install -D -m 0644 debian/bug/live-helper.presubj debian/live-helper/usr/share/bug/live-helper/presubj
- install -D -m 0755 debian/bug/live-helper.script debian/live-helper/usr/share/bug/live-helper/script
-
-binary: binary-indep
-
-binary-arch:
-binary-indep: install
- dh_testdir
- dh_testroot
+override_dh_installchangelogs:
dh_installchangelogs docs/ChangeLog
- dh_installdocs
- dh_installlogrotate
- dh_installcron
- dh_installman
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-.PHONY: clean build install binary binary-arch binary-indep